Problem with browser when update to 4.1.2015.12164

TeeChart for Microsoft Visual Studio .NET, Xamarin Studio (Android, iOS & Forms) & Monodevelop.
Post Reply
Hermes
Newbie
Newbie
Posts: 6
Joined: Wed May 20, 2015 12:00 am

Problem with browser when update to 4.1.2015.12164

Post by Hermes » Fri Mar 04, 2016 1:41 pm

Hi, I have an strange problem since I've updated to 4.1.2015.12164.
The Chart is showed in Chrome (Versión 48.0.2564.116 m) but not in Internet Explorer (Versión 11.0.9600.18205).

Thank you
Attachments
IE11.jpg
IE 11
IE11.jpg (139.29 KiB) Viewed 3782 times
ThreePoints.jpg
In Chrome
ThreePoints.jpg (197.05 KiB) Viewed 3773 times

Marc
Site Admin
Site Admin
Posts: 991
Joined: Thu Oct 16, 2003 4:00 am
Location: Girona
Contact:

Re: Problem with browser when update to 4.1.2015.12164

Post by Marc » Fri Mar 04, 2016 3:34 pm

Hello,

What is the TempChart property set to? If this worked correctly for you with a previous version, are you tell me what version that was?

With thanks.
Regards,
Marc

Hermes
Newbie
Newbie
Posts: 6
Joined: Wed May 20, 2015 12:00 am

Re: Problem with browser when update to 4.1.2015.12164

Post by Hermes » Tue Apr 05, 2016 8:58 pm

Hi, the version was the immediately before, we always update when an update arrived.
Because we needed to make a demo, I discovered that when there is not a connected net on the notebook, the problem not exists.
Is something with the image temporary directory, but I don't figure what.

<tchart:WebChart ID="WebChart1" runat="server" Height="400px" Width="1200px" Style="position: relative" AutoPostback="False" GetChartFile="GetChart.aspx" TempChart="File" Config="AAEAAAD/////AQAAAAAAAAAMAgAAAFFUZWVDaGFydCwgVmVyc2lvbj00LjEuMjAxNS4zMTE0LCBDdWx0dXJlPW5ldXRyYWwsIFB1YmxpY0tleVRva2VuPTljODEyNjI3NmM3N2JkYjcFAQAAABVTdGVlbWEuVGVlQ2hhcnQuQ2hhcnQDAAAADC5DYW5jZWxNb3VzZRAuQ3VzdG9tQ2hhcnRSZWN0GS5Bc3BlY3QuQ29sb3JQYWxldHRlSW5kZXgAAAABAQgCAAAAAAAAAAAACw==" />

WebChart1.TempChart = Steema.TeeChart.Web.TempChartStyle.Session;

regards

Marc
Site Admin
Site Admin
Posts: 991
Joined: Thu Oct 16, 2003 4:00 am
Location: Girona
Contact:

Re: Problem with browser when update to 4.1.2015.12164

Post by Marc » Thu Apr 07, 2016 12:18 pm

Hello,

I've tried a few tests with the latest version and haven't been able to reproduce the problem with TempChart both as session or file. If you have a sample project that reproduces the problem it would be useful. In your description you state that WebChart TempChart is set as session:
ie.

Code: Select all

WebChart1.TempChart = Steema.TeeChart.Web.TempChartStyle.Session;
but the example code from the webpage shows:

Code: Select all

 TempChart="File"
A working example project that reproduces the problem would help me understand how that is running.

Thinking on... assuming that session is running correctly and there is a difference between Chrome and Internet Explorer for the same chart-page then check that cookies are not being blocked in IE. That wouldn' explain why it didn't happen for the previous version of TeeChart though and doesn't answer the question of why this is ok on a notebook not connected to a network. ... it has a local server I assume (?). ... then maybe IE security zone could be worth looking at.

With thanks.
Regards,
Marc
Steema Support

Post Reply