From D2007 and v2012.07.120914 to XE6 and 2014

TeeChart VCL for Borland/CodeGear/Embarcadero RAD Studio, Delphi and C++ Builder.
Post Reply
johnnix
Newbie
Newbie
Posts: 37
Joined: Thu Nov 28, 2013 12:00 am

From D2007 and v2012.07.120914 to XE6 and 2014

Post by johnnix » Sat Jun 14, 2014 9:13 pm

Hello,

I am in the process of importing my D2007 projects to the latest XE6. I heavily use charts and I noticed that the charts within XE6 have lost the visual properties. Is there a way that I can maintain their appearance? Also it appears that by default the GDI+ engine is enabled and using the options menu does not have an affect (after I set Render to GDI)

Regards

Yeray
Site Admin
Site Admin
Posts: 8746
Joined: Tue Dec 05, 2006 12:00 am
Location: Girona, Catalonia
Contact:

Re: From D2007 and v2012.07.120914 to XE6 and 2014

Post by Yeray » Mon Jun 16, 2014 10:04 am

Hello,
johnnix wrote:I am in the process of importing my D2007 projects to the latest XE6. I heavily use charts and I noticed that the charts within XE6 have lost the visual properties. Is there a way that I can maintain their appearance?
Could you please specify what exact visual properties you've noticed to be lost?
johnnix wrote:Also it appears that by default the GDI+ engine is enabled and using the options menu does not have an affect (after I set Render to GDI)
The behaviour should be different depending on the item you have selected in the "Render" combobox at the "New Chart" tab at the design time options. Note this option is saved at the registry entry:
HKEY_CURRENT_USER\Software\Steema Software\TeeChart Pro\Editor\DefaultCanvas
- a blank string '' is the value set for the GDI canvas.
- 'TGDIPlusCanvas' is the value set for GDI+.

If I set this combobox to GDI, when I load a tee file created with v2012.07, that uses GDI, I still have a chart with GDI.
However, if I set this combobox to GDI+, when I load the same tee file created with v2012.07, that uses GDI, I have a chart with GDI+.

See the attached project built with v2012.07, the tee file created with it, and the same project built with v2014.11 that loads the tee file as described above for me here.
Upgrade.zip
(1.85 MiB) Downloaded 161 times
Best Regards,
ImageYeray Alonso
Development & Support
Steema Software
Av. Montilivi 33, 17003 Girona, Catalonia (SP)
Image Image Image Image Image Image Please read our Bug Fixing Policy

johnnix
Newbie
Newbie
Posts: 37
Joined: Thu Nov 28, 2013 12:00 am

Re: From D2007 and v2012.07.120914 to XE6 and 2014

Post by johnnix » Mon Jun 16, 2014 11:41 am

Hello Yeray,

It looks like that the tick marks color is now set at white, I lost the pen width of the axis, there is something wrong with the margin values (left axis caption is half visible cause it now moved close and over the edge of the component) but most important when I open the D2007 project file with XE6 everything appear to be drawn with GDI+. My first concern is how I can prevent that (I already check the registry settings and the default canvas entry is blank). Indeed if I drop a new TChart object on a form it is obvious that GDI is used.

Regards

John

johnnix
Newbie
Newbie
Posts: 37
Joined: Thu Nov 28, 2013 12:00 am

Re: From D2007 and v2012.07.120914 to XE6 and 2014

Post by johnnix » Mon Jun 16, 2014 12:32 pm

Also I need to open all my forms that have a TChart component to resolve an issue with the Font.Gradient.Outline property not existing

johnnix
Advanced
Posts: 192
Joined: Tue Jul 10, 2007 12:00 am

Re: From D2007 and v2012.07.120914 to XE6 and 2014

Post by johnnix » Mon Jun 16, 2014 1:02 pm

Here are 2 images to see how the new charts appear after importing the project file to XE6 (no code changes).
Attachments
Xe6.png
Xe6.png (137.15 KiB) Viewed 4110 times
D2007.png
D2007.png (86.2 KiB) Viewed 4104 times

Yeray
Site Admin
Site Admin
Posts: 8746
Joined: Tue Dec 05, 2006 12:00 am
Location: Girona, Catalonia
Contact:

Re: From D2007 and v2012.07.120914 to XE6 and 2014

Post by Yeray » Tue Jun 17, 2014 9:14 am

Hi John,
johnnix wrote:It looks like that the tick marks color is now set at white
Do you mean the axis labels drawn on the ticks or the series marks?
johnnix wrote:I lost the pen width of the axis
Can't reproduce this here.
johnnix wrote:there is something wrong with the margin values (left axis caption is half visible cause it now moved close and over the edge of the component)
Can't reproduce this here.
johnnix wrote:but most important when I open the D2007 project file with XE6 everything appear to be drawn with GDI+. My first concern is how I can prevent that (I already check the registry settings and the default canvas entry is blank). Indeed if I drop a new TChart object on a form it is obvious that GDI is used.
Can't reproduce this here.

I've made a simple project with just a v2012.07 chart on a form and a TBarSeries. I've modified the left axis pen width and I've set a title to the left axis. Then I've saved the project and opened it with XE6 and TeeChart v2014.11. I see the chart still uses GDI, conserves the axis pen width, margin in the left axis title and I see no white labels at the axes nor at the bar marks.

Could you please arrange a simple example project we can run as-is to reproduce the problem here?
Thanks in advance.
Best Regards,
ImageYeray Alonso
Development & Support
Steema Software
Av. Montilivi 33, 17003 Girona, Catalonia (SP)
Image Image Image Image Image Image Please read our Bug Fixing Policy

johnnix
Newbie
Newbie
Posts: 37
Joined: Thu Nov 28, 2013 12:00 am

Re: From D2007 and v2012.07.120914 to XE6 and 2014

Post by johnnix » Tue Jun 17, 2014 7:16 pm

Yeray,

Please find attached a project where you can see the most critical issues I am facing. After running try to zoom out, you will notice a dotted frame that appears around the chart (like it is selected) and the text inside looses transparency (that exact code works ok with my 2012 version)

Regards
Attachments
Test Project.zip
(57.37 KiB) Downloaded 150 times

johnnix
Newbie
Newbie
Posts: 37
Joined: Thu Nov 28, 2013 12:00 am

Re: From D2007 and v2012.07.120914 to XE6 and 2014

Post by johnnix » Tue Jun 17, 2014 7:18 pm

Also try clicking the button to see how the GDI+ affects the chart, tick marks do not appear, text is replaced with '-' ....

Yeray
Site Admin
Site Admin
Posts: 8746
Joined: Tue Dec 05, 2006 12:00 am
Location: Girona, Catalonia
Contact:

Re: From D2007 and v2012.07.120914 to XE6 and 2014

Post by Yeray » Wed Jun 18, 2014 2:43 pm

Hello John,

Let me comment the problems/issues I see:

- Transparent background lost after unzoom in GDI:
It seems setting Zoom.Brush.Style to bsSolid is causing this.
Removing it from the dfm or adding this at OnCreate seems to fix this:

Code: Select all

Chart1.Zoom.Brush.Style:=bsClear;
- Dotted frame around the chart after unzoom in GDI:
This seems to happen when you set Zoom.Pen.SmallDots to true and BevelOuter to bvNone.
Change any of these properties to workaround this.

- Text "-" in GDIPlus.
In previous versions I see nothing is drawn with the same code.
It seems GDIPlus don't accept negative Sizes in fonts.
This is fixed if you change the font size from "-12" to "12".
Or you can use Height instead of Size:

Code: Select all

  fnt.Height := -12;
Best Regards,
ImageYeray Alonso
Development & Support
Steema Software
Av. Montilivi 33, 17003 Girona, Catalonia (SP)
Image Image Image Image Image Image Please read our Bug Fixing Policy

johnnix
Newbie
Newbie
Posts: 37
Joined: Thu Nov 28, 2013 12:00 am

Re: From D2007 and v2012.07.120914 to XE6 and 2014

Post by johnnix » Wed Jun 18, 2014 3:31 pm

Hello Yeray,

Since I am a source code customer is it possible to suggest a fix for the issue with the zoom out and dotted frame without having to change any of the settings you mentioned?

Regards

johnnix
Newbie
Newbie
Posts: 37
Joined: Thu Nov 28, 2013 12:00 am

Re: From D2007 and v2012.07.120914 to XE6 and 2014

Post by johnnix » Thu Jun 19, 2014 7:01 pm

Hello Yeray,

The solution you suggested for the brush style does not work. Any other suggestions?

Regards

Yeray
Site Admin
Site Admin
Posts: 8746
Joined: Tue Dec 05, 2006 12:00 am
Location: Girona, Catalonia
Contact:

Re: From D2007 and v2012.07.120914 to XE6 and 2014

Post by Yeray » Fri Jun 20, 2014 10:09 am

Hello John,
johnnix wrote:Since I am a source code customer is it possible to suggest a fix for the issue with the zoom out and dotted frame without having to change any of the settings you mentioned?
I'll add it to the public tracker:
http://bugs.teechart.net/show_bug.cgi?id=808
Feel free to add your mail to the CC list to be automatically notified when an update arrives.
When the ticket will be closed, we will be able to tell you if the fix can be easily applied to an old source code version or not.
johnnix wrote:The solution you suggested for the brush style does not work. Any other suggestions?
After some further tests I've seen populating the series also seems to affects the brush of the texts custom drawn.
I've added this to the public tracker too:
http://bugs.teechart.net/show_bug.cgi?id=807
Best Regards,
ImageYeray Alonso
Development & Support
Steema Software
Av. Montilivi 33, 17003 Girona, Catalonia (SP)
Image Image Image Image Image Image Please read our Bug Fixing Policy

johnnix
Newbie
Newbie
Posts: 37
Joined: Thu Nov 28, 2013 12:00 am

Re: From D2007 and v2012.07.120914 to XE6 and 2014

Post by johnnix » Fri Jun 20, 2014 12:37 pm

Thank you very much :)

Post Reply