Issue with OnBeforeDrawChart

TeeChart VCL for Borland/CodeGear/Embarcadero RAD Studio, Delphi and C++ Builder.
Post Reply
johnnix
Newbie
Newbie
Posts: 34
Joined: Tue Sep 18, 2018 12:00 am

Issue with OnBeforeDrawChart

Post by johnnix » Sat May 11, 2019 7:08 am

Hello,

I need to have the plot area (area between axes) painted in white so I added some code in the OnBeforeDrawChart event. When I start the app the area inside the plot is painted with the default colour and once I move the mouse inside the event code executes well. Is there a way to fix this? I tried calling TChart.Draw when the form is shown but no luck.

I am using the latest TChart version
Attachments
Project1.zip
(5.59 KiB) Downloaded 68 times

Yeray
Site Admin
Site Admin
Posts: 8746
Joined: Tue Dec 05, 2006 12:00 am
Location: Girona, Catalonia
Contact:

Re: Issue with OnBeforeDrawChart

Post by Yeray » Tue May 21, 2019 7:16 am

Hello,

Adding the aChart.Draw call at FormCreate works for me using RAD 10.3 Rio and TeeChart Pro v2018.26:
OnBeforeDrawChart.zip
(2.14 KiB) Downloaded 73 times
If you still find problems with this, please tell us what environment are you using.
Best Regards,
ImageYeray Alonso
Development & Support
Steema Software
Av. Montilivi 33, 17003 Girona, Catalonia (SP)
Image Image Image Image Image Image Please read our Bug Fixing Policy

johnnix
Newbie
Newbie
Posts: 34
Joined: Tue Sep 18, 2018 12:00 am

Re: Issue with OnBeforeDrawChart

Post by johnnix » Wed May 22, 2019 4:54 am

Thank you for your reply, that seems to do the trick :)

Post Reply