Metafile rendered incorrectly, Bitmap is fine

TeeChart VCL for Borland/CodeGear/Embarcadero RAD Studio, Delphi and C++ Builder.
Post Reply
Ed Dressel
Newbie
Newbie
Posts: 28
Joined: Tue Dec 05, 2017 12:00 am

Metafile rendered incorrectly, Bitmap is fine

Post by Ed Dressel » Mon Jun 25, 2018 11:32 pm

Seattle, Projects/Options/Application: Enable High-DPI turned off

I know I posted this in a previous thread, but the subject and problem changed from the initial post and I didn't get a response from my last post (dated June 7th) which is very unusual.

In creating an graphic from a chart (which I do extensively for reports), if Text Size in Windows' Display Settings are antying other than 100%, metafile's are rendered incorrectly. This is not the case with bitmaps--they are rendered correctly. Here is what is seen then the Text Size is 100% (I kept the chart as simple as possible to show the problem):

Image

If I change the Text Size to 200% and re-render the graphic as a metafile, here is what I see:

Image

Finally, a bitmap rendering works fine:

Image

This bug creates incorrect image sizes in my report. If I switch the images to bitmaps, they appear pixelated.

Why does it work right with a bitmap but not a metafile?

How can I get this to work correctly? It is critical for me.

Much appreciated,

Ed Dressel
Attachments
Image Size.zip
(52.07 KiB) Downloaded 115 times

Ed Dressel
Newbie
Newbie
Posts: 28
Joined: Tue Dec 05, 2017 12:00 am

Re: Metafile rendered incorrectly, Bitmap is fine

Post by Ed Dressel » Tue Jul 17, 2018 3:38 pm

No response?

Marc
Site Admin
Site Admin
Posts: 933
Joined: Thu Oct 16, 2003 4:00 am
Location: Girona
Contact:

Re: Metafile rendered incorrectly, Bitmap is fine

Post by Marc » Fri Jul 20, 2018 10:14 am

Hello Ed,

Sorry for the silence in our part. This is a problem that has been looked into more than once without a satisfactory result. We'll give it another try. Apologies once again for the inconvenience and delay.

Regards,
Marc Meumann
Steema Support

Marc
Site Admin
Site Admin
Posts: 933
Joined: Thu Oct 16, 2003 4:00 am
Location: Girona
Contact:

Re: Metafile rendered incorrectly, Bitmap is fine

Post by Marc » Mon Jul 23, 2018 12:06 pm

Hello Ed,

I attach this project for discussion. It may not meet your needs in some respects so please let us know with feedback.

This project creates a metafile as a result of a chart on a form and renders it to a TImage, you can drag resize the form to see the metafile react. The project assumes a potential screen width of 1920 pixels and bases scaling on that when Windows display size is changed.

Note, the metafile is generated at the standard Chart dimension, taking thus font size 'as is'. The redimension takes place as a 'stretch-fit' to the image container. As the metafile is vectorial it maintains quality.

I hope that may help as a start to arriving at a satisfactory solution.

Regards,
Marc
DisplaySize.zip
metafile display sizing example
(52.63 KiB) Downloaded 152 times
Steema Support

marder
Advanced
Posts: 115
Joined: Thu May 29, 2008 12:00 am

Re: Metafile rendered incorrectly, Bitmap is fine

Post by marder » Wed Oct 16, 2019 2:53 pm

Is there any news on this topic?

Marc
Site Admin
Site Admin
Posts: 933
Joined: Thu Oct 16, 2003 4:00 am
Location: Girona
Contact:

Re: Metafile rendered incorrectly, Bitmap is fine

Post by Marc » Tue Oct 22, 2019 8:16 am

Hello,

As far as we're aware, the proposed solution responds to the requirement. We do not intend to take this any further unless a note is raised on any particular aspect.

Regards,
Marc Meumann
Steema Support

Post Reply