New TeeChart for PHP install

TeeChart for PHP
streamfoundry
Newbie
Newbie
Posts: 10
Joined: Tue Oct 23, 2007 12:00 am
Contact:

New TeeChart for PHP install

Post by streamfoundry » Wed Nov 11, 2009 5:47 pm

Hello - we are a current TeeChart Pro ActiveX 8.0 customer - looking to evaluate TeeChart for PHP V1. We have a current native PHP environment working under Apache on z/OS. We downloaded the evaluation copy of TeeChart for PHP V1, unzipped the download and uploaded it to our Apache environment. When we try to access ...demos/Features/index.php, we get the following error:
"require_once(vcl/vcl.inc.php) [function.require-once]: HPH00681 failed to open stream: EDC5129I No such file or directory"
We find no "vcl" directory in the download. Can you tell us what we are missing?

Thank you.

Pep
Site Admin
Site Admin
Posts: 3165
Joined: Fri Nov 14, 2003 5:00 am
Contact:

Re: New TeeChart for PHP install

Post by Pep » Thu Nov 12, 2009 12:34 pm

Hello,

the index.php, and index.xml.php are not used, we forgot to remove from the zip file. You can just remove them and call the index.php file instead.
As you're using the Eval version, remember to upload the loader to your server (you can find the link to download them at the install.txt file), and then add it as one php extension.

Please, do not hesitate to contact us if you still having problems.

streamfoundry
Newbie
Newbie
Posts: 10
Joined: Tue Oct 23, 2007 12:00 am
Contact:

Re: New TeeChart for PHP install

Post by streamfoundry » Mon Nov 16, 2009 6:25 pm

Hi - don't know what you mean by "the index.php, and index.xml.php are not used, we forgot to remove from the zip file. You can just remove them and call the index.php file instead.". Did you mean to say "...call the index.html file instead"?

streamfoundry
Newbie
Newbie
Posts: 10
Joined: Tue Oct 23, 2007 12:00 am
Contact:

Re: New TeeChart for PHP install

Post by streamfoundry » Mon Nov 16, 2009 6:54 pm

Also - I downloaded the phpexpress-2.0 loaders and I don't see one we could use for z/OS Unix System Services. These are the loaded that I see:

phpexpress-2.0-FreeBSD-4.tar.gz
phpexpress-2.0-FreeBSD-6.tar.gz
phpexpress-2.0-Linux-glibc-2.3.tar.gz
phpexpress-2.0-Linux-glibc-2.7.tar.gz
phpexpress-2.0-MacOSX-10.5.tar.gz
phpexpress-2.0-NetBSD-3.tar.gz
phpexpress-2.0-OpenBSD-4.tar.gz
phpexpress-2.0-SunOS-5.8.tar.gz
phpexpress-2.0-SunOS-5.10.tar.gz

Yeray
Site Admin
Site Admin
Posts: 8725
Joined: Tue Dec 05, 2006 12:00 am
Location: Girona, Catalonia
Contact:

Re: New TeeChart for PHP install

Post by Yeray » Tue Nov 17, 2009 12:01 pm

Hi streamfoundry,
streamfoundry wrote:Hi - don't know what you mean by "the index.php, and index.xml.php are not used, we forgot to remove from the zip file. You can just remove them and call the index.php file instead.". Did you mean to say "...call the index.html file instead"?
Yes, Pep meant that you can delete safely that two php files and call the index.html instead.
streamfoundry wrote:Also - I downloaded the phpexpress-2.0 loaders and I don't see one we could use for z/OS Unix System Services.
I think that you could try with the phpexpress-2.0-Linux-glibc-2.7.tar.gz
Best Regards,
ImageYeray Alonso
Development & Support
Steema Software
Av. Montilivi 33, 17003 Girona, Catalonia (SP)
Image Image Image Image Image Image Please read our Bug Fixing Policy

streamfoundry
Newbie
Newbie
Posts: 10
Joined: Tue Oct 23, 2007 12:00 am
Contact:

Re: New TeeChart for PHP install

Post by streamfoundry » Tue Nov 17, 2009 5:49 pm

Hi - thanks for the response - rather than continue on our z/OS USS Apache server - I moved this effort of demo'ing TeeChart for PHP onto our z/Linux-based application. From the list of available loaders, I chose the "phpexpress-2.0-Linux-glibc-2.7.tar.gz" flavor. Had my doubts when I saw that two versions were under that - one for x86 and one for x86-64. Being on SLES10 (64 bit), I chose the x86-64 loader (phpexpress-php-5.2.so) - but it wouldn't load at Apache startup time (not surprised) - got:

PHP Warning: PHP Startup: Unable to load dynamic library '/usr/lib64/php5/extensions/phpexpress-php-5.2.so' -/user/lib64/php5/extensions/phpexpress-php-5.2.so: ELF file data encoding not big-endian in Unknown on line 0

I guess a couple questions are in order now - has "TeeChart for PHP" been testing on a z/Linux platform? If so, what phpexpress loader is available to use? We're running PHP Ver 5.2.11.dev on Apache 2.2.3.

Dan St.Cyr
StreamFoundry, Inc.

Yeray
Site Admin
Site Admin
Posts: 8725
Joined: Tue Dec 05, 2006 12:00 am
Location: Girona, Catalonia
Contact:

Re: New TeeChart for PHP install

Post by Yeray » Wed Nov 18, 2009 10:57 am

Hi Dan,

Yes, I've made a test in a fresh install of Ubuntu 9.10 the last week and I've found some problems with GD library but I managed to run it by recompiling the PHP following this instructions.
See the attached example that worked for me here:
a.zip
(342 Bytes) Downloaded 651 times
And the result:
screenshot.png
screenshot.png (129.26 KiB) Viewed 14714 times
What we haven't tried is in 64 bits.
Best Regards,
ImageYeray Alonso
Development & Support
Steema Software
Av. Montilivi 33, 17003 Girona, Catalonia (SP)
Image Image Image Image Image Image Please read our Bug Fixing Policy

streamfoundry
Newbie
Newbie
Posts: 10
Joined: Tue Oct 23, 2007 12:00 am
Contact:

Re: New TeeChart for PHP install

Post by streamfoundry » Wed Nov 18, 2009 7:15 pm

Yeray - I tried your example, rather than the demo - but I'm still needing a PhpExpress loader for z/Linux (see my last post):

The example error as follows: "file /srv/www/cms41/teechart/sources/TChart.php requires Php Express loader to be installed by the web site administrator."

I asked NuSphere for it (http://forum.nusphere.com/viewtopic.php?p=25414#25414) but haven't gotten a response yet.

streamfoundry
Newbie
Newbie
Posts: 10
Joined: Tue Oct 23, 2007 12:00 am
Contact:

Re: New TeeChart for PHP install

Post by streamfoundry » Mon Nov 23, 2009 1:09 pm

Hello Steema support: Any luck in finding a PhpExpress loader for Apache on z/Linux? Again - I'm running SUSE on z/Linux (SLES10) and Apache can't load the extension for the version of PhpExpress loader I guessed at during startup (see previous post for error message). Prior to purchasing TeeChart for PHP, I need to evaluate it on our environment.

Thanks,

Dan St.Cyr
StreamFoundry, Inc.

Yeray
Site Admin
Site Admin
Posts: 8725
Joined: Tue Dec 05, 2006 12:00 am
Location: Girona, Catalonia
Contact:

Re: New TeeChart for PHP install

Post by Yeray » Tue Nov 24, 2009 10:01 am

Hi Dan,

Excuse us for the delay. We are not very familiar to linux as we don't usually use it.
I made instructions trying to explain the process from where I could get TeeChartforPHP work in an Ubuntu 9.10:
  • Fresh install Ubuntu 9.10
    - Update through update manager
    - Install php5 through synaptic
    - sudo mkdir /var/www/TeeChartForPHP
    - Download TeeChartForPHP
    - Unzip the content in TeeChartPHP1Evaluation.zip to /var/www/TeeChartForPHP
    - Download and place a.php into /var/www/
    - sudo chmod -R 777 /var/www/
    - Rename the file /var/www/TeeChartForPHP/sources/themes/y2009.php to /var/www/TeeChartForPHP/sources/themes/Y2009.php
    - Browsing to http://localhost/a.php gives the following:
    "file /var/www/TeeChartForPHP/sources/TChart.php requires Php Express loader to be installed by the web site administrator."


    If I...
    - Download http://www.steema.com/products/teechart ... oaders.zip
    - Unzip the phpexpress-php-5.2.so file from loaders.zip/loader/phpexpress-2.0-Linux-glibc-2.7.tar.gz/phpexpress-2.0-Linux-glibc-2.7/x86/ to /var/www/extensions/
    - Edit the php.ini file to load the phpexpress extensions:
    • - sudo gedit /etc/php5/apache2/php.ini
      • - At line 508: extension_dir = "/var/www/extensions/"
        - At line 621: extension=phpexpress-php-5.2.so
    Browsing to http://localhost/a.php gives the following:
    Fatal error: Call to undefined function imagecreatetruecolor() in /var/www/TeeChartForPHP/sources/GraphicsGD.php on line 698


    To solve this, we have to recompile php5 as explained in the web said above:
    - sudo apt-get install build-essential debhelper fakeroot
    - cd /usr/src
    - sudo apt-get source php5
    - sudo apt-get build-dep php5
    - cd php5-5.2.10.dfsg.1
    - sudo gedit debian/rules
    • at line 220: --with-gd=shared --enable-gd-native-ttf \
    - sudo dpkg-buildpackage -rfakeroot (this can take a while, be patient)
    - cd ..
    - sudo dpkg -i php5-gd_5.2.10.dfsg.1-2ubuntu6.1_i386.deb

    At this point, having enabled the nusphere loaders, the GD library isn't loaded successfully and it gives me an error so I had to comment the lines I've added in the php.ini
    - sudo /etc/init.d/apache2 restart

    Now you should see a chart if you open a browser and call http://localhost/a.php
Another test you could do would be adding the phpinfo(); call in your a.php file and see if the GD library is correctly loaded:
phpinfo()_GDLib.png
phpinfo()_GDLib.png (109.93 KiB) Viewed 14629 times
Best Regards,
ImageYeray Alonso
Development & Support
Steema Software
Av. Montilivi 33, 17003 Girona, Catalonia (SP)
Image Image Image Image Image Image Please read our Bug Fixing Policy

Yeray
Site Admin
Site Admin
Posts: 8725
Joined: Tue Dec 05, 2006 12:00 am
Location: Girona, Catalonia
Contact:

Re: New TeeChart for PHP install

Post by Yeray » Tue Nov 24, 2009 11:32 am

Hi Dan,

Ah, I forgot to mention that I've found problems trying to open the file GraphicsGD.php. So I changed it for the following that is readable for me:
Attachments
GraphicsGD.zip
(20.51 KiB) Downloaded 636 times
Best Regards,
ImageYeray Alonso
Development & Support
Steema Software
Av. Montilivi 33, 17003 Girona, Catalonia (SP)
Image Image Image Image Image Image Please read our Bug Fixing Policy

streamfoundry
Newbie
Newbie
Posts: 10
Joined: Tue Oct 23, 2007 12:00 am
Contact:

Re: New TeeChart for PHP install

Post by streamfoundry » Tue Nov 24, 2009 1:30 pm

Yeray - I see what you're saying about your Ubuntu install, but I don't think it's relevant to the problem I've got - which is the fact that I can't enable a PhpExpress loader. All those /sources/ php scripts (including the Y2009.php you tested on Ubuntu with) are encoded with NuSphere's Nu-Coder product and thus HAVE to be decoded with NuSphere's PHPExpress. You HAVE to have a loader enabled on Ubuntu or you would have gotten the same error I did ("file /srv/www/cms41/teechart/sources/TChart.php requires Php Express loader to be installed by the web site administrator." ) trying to run your example code . That error text is coded right into all your encoded scripts by Nu-Coder. 1st order of business in running ANY of your PHP scripts is to be able to decode it! Then, we can address any logic errors that might come up.
The key to me not being able to enable phpexpress-php-5.2.so as a php extension at Apache startup is that I get this error:
"ELF file data encoding not big-endian in Unknown on line 0"
This makes sense because our platform is a "z" (mainframe) platform - not x86.
I need a PhpExpress loader that is compatible with a z/Linux platform. As I indicated earlier, I opened a forum topic with NuSphere ( http://forum.nusphere.com/viewtopic.php?t=6645 ) - but so far it's being ignored. If you have ANY influence with Nusphere, please help me out.

Thanks,

Dan St.Cyr

Yeray
Site Admin
Site Admin
Posts: 8725
Joined: Tue Dec 05, 2006 12:00 am
Location: Girona, Catalonia
Contact:

Re: New TeeChart for PHP install

Post by Yeray » Tue Nov 24, 2009 4:39 pm

Hi Dan,

I've just updated the instructions above.
streamfoundry wrote:You HAVE to have a loader enabled on Ubuntu or you would have gotten the same error I did ("file /srv/www/cms41/teechart/sources/TChart.php requires Php Express loader to be installed by the web site administrator." ) trying to run your example code .
Excuse me because in the first instructions I removed the part where I use the nusphere loaders because, after compiling the php5, I had to remove them. I'm not sure why it works in this way... :?

Anyway, we'll try to contact to nusphere people and see if they can give us more information about your environment.
Best Regards,
ImageYeray Alonso
Development & Support
Steema Software
Av. Montilivi 33, 17003 Girona, Catalonia (SP)
Image Image Image Image Image Image Please read our Bug Fixing Policy

streamfoundry
Newbie
Newbie
Posts: 10
Joined: Tue Oct 23, 2007 12:00 am
Contact:

Re: New TeeChart for PHP install

Post by streamfoundry » Tue Nov 24, 2009 5:40 pm

Interesting, Yeray - that you got the same error I did originally, saying that TChart.php needed the PhpExpress loader. You installed one and apparently got by that error because you then got a later error in GraphicsGD.php. Yet, after recompiling PHP for enabling GD support, you disabled the loader and didn't get the original error back? Pretty strange. Do you have a copy of the resulting php.ini extension statements? You sure the extension=phpexpress-php-5.2.so statement isn't still in there? In any event, I'd like to follow your install exactly so I still need a z-platform PhpExpress loader before I can go any further. If/when NuSphere can get me one that will load, I'll then address the GD enabling if we find I need to. Let me know what they say. Thanks, Yeray.

Dan

Yeray
Site Admin
Site Admin
Posts: 8725
Joined: Tue Dec 05, 2006 12:00 am
Location: Girona, Catalonia
Contact:

Re: New TeeChart for PHP install

Post by Yeray » Wed Nov 25, 2009 9:26 am

Hi Dan,
streamfoundry wrote:Interesting, Yeray - that you got the same error I did originally, saying that TChart.php needed the PhpExpress loader. You installed one and apparently got by that error because you then got a later error in GraphicsGD.php.
Yes. Excuse me if I confused you. As I had to disable the loaders at the end of the process, I thought I could skip that in my "installing instructions".
streamfoundry wrote:Yet, after recompiling PHP for enabling GD support, you disabled the loader and didn't get the original error back? Pretty strange.
Yes, in a few words the process I made was:
- error of phpexpress loaders -> enable phpexpress loaders
- error of GD library -> recompile php
- error of GD library -> disable phpexpress loaders enabled before

I assumed that the phpexpress loaders weren't needed at all. But maybe recompiling the php with them enabled has something to say here... :?
streamfoundry wrote:Do you have a copy of the resulting php.ini extension statements?
Of course, here it is:
php.zip
(14.84 KiB) Downloaded 623 times
streamfoundry wrote:You sure the extension=phpexpress-php-5.2.so statement isn't still in there?
After loading them in the beginning of the process, I could see them enabled running the phpinfo function.
nusphere-loaders-phpinfo().png
nusphere-loaders-phpinfo().png (71.53 KiB) Viewed 14625 times
And at the end of the process, after removing them from the php.ini, I can't find them in the phpinfo function result, but the chart seems to work without problems. :shock: + :? = 8)
streamfoundry wrote:In any event, I'd like to follow your install exactly so I still need a z-platform PhpExpress loader before I can go any further.
Yes, I'll try to clarify any step in my installation you could find problems with. Also, I can try to upload the vmware virtual machine where I have the "working" ubuntu, if you want to take a look at it.
streamfoundry wrote:If/when NuSphere can get me one that will load, I'll then address the GD enabling if we find I need to. Let me know what they say.
Of course. I hope they'll answer asap.
Best Regards,
ImageYeray Alonso
Development & Support
Steema Software
Av. Montilivi 33, 17003 Girona, Catalonia (SP)
Image Image Image Image Image Image Please read our Bug Fixing Policy

Post Reply