Search found 9 matches

by kville
Thu Nov 24, 2011 7:32 am
Forum: VCL
Topic: TeeChart Pro V2011.04 - Delphi 2010 binary installer failed
Replies: 13
Views: 8076

Re: TeeChart Pro V2011.04 - Delphi 2010 binary installer failed

I seem to have the same problem. Got the same "TeeChart files to AUTO install cannot be found" message while installing. Then I Removed all (also older) TeeChart instances and reinstalled "TeeChart Pro for RAD XE". Same message during install as before. And when I am opening the C++ Builder project ...
by kville
Thu Apr 07, 2011 10:52 am
Forum: VCL
Topic: Contourplot with white triangles ...
Replies: 16
Views: 10965

Re: Contourplot with white triangles ...

Is there any news on this subject or estimate when this will be corrected?
by kville
Thu Apr 07, 2011 10:35 am
Forum: VCL
Topic: [SOLVED] Contour not drawing correctly
Replies: 12
Views: 6385

Re: Contour not drawing correctly

Code: Select all

// Remove default/old entries from series
for (int i = 0; i < Series1->Count(); i++) {
   Series1->Delete(i);
}
Answering for myself, the above will not work because if index 0 is deleted index 1 will become new index 0.
by kville
Thu Apr 07, 2011 9:47 am
Forum: VCL
Topic: [SOLVED] Contour not drawing correctly
Replies: 12
Views: 6385

Re: Contour not drawing correctly

Thank you for the Excel files, they were really helpful for pointing out why the population was unsuccessful. I actually thought that the chart was populated with 16 (4x4 grid) values all the time and did not suspect that the data corrupted such way. Further investigation showed that the following c...
by kville
Thu Apr 07, 2011 6:55 am
Forum: VCL
Topic: [SOLVED] Contour not drawing correctly
Replies: 12
Views: 6385

Re: Contour not drawing correctly

1. Actually the problem only occurs when I do not have any zero values anymore on the grid. The chart plots just fine until the last zero value is changed to non zero value and the chart is cleared and populated with values from the fully populated stringgrid. 2. Before posting here I had already tr...
by kville
Thu Mar 31, 2011 6:29 am
Forum: VCL
Topic: [SOLVED] Contour not drawing correctly
Replies: 12
Views: 6385

Re: Contour not drawing correctly

Our application must be populated one by one, so this will not solve the problem. EDIT: In fact my application loads all values too, the ones not clicked are filled with default value. So actually the chart will always contain as many values as there are cells in the grid. Only difference between my...
by kville
Tue Mar 29, 2011 7:21 am
Forum: VCL
Topic: [SOLVED] Contour not drawing correctly
Replies: 12
Views: 6385

Re: Contour not drawing correctly

I attached the sample project + exe for testing. To reproduce the problem you have to populate grid cells (cells are populated by double clicking them) in specified order explained below: 1 2 3 4 8 7 6 5 16 15 14 13 9 10 11 12 The Chart can be corrected (after populating it fully) by clicking the re...
by kville
Tue Mar 29, 2011 4:28 am
Forum: VCL
Topic: [SOLVED] Contour not drawing correctly
Replies: 12
Views: 6385

Re: Contour not drawing correctly

I have a sample C++ builder project that I could send to you, but I do not know where or how it should be uploaded.
by kville
Thu Mar 24, 2011 12:11 pm
Forum: VCL
Topic: [SOLVED] Contour not drawing correctly
Replies: 12
Views: 6385

[SOLVED] Contour not drawing correctly

I have a simple project using TeeChart Pro VCL in Embarcadero C++ Builder XE. In this project I populate a Contour chart using values in a StringGrid. Problem is that sometimes the contour draws incorrectly. I have tried dozens of different approaches so far, but nothing seems to help. I attached an...