Search found 65 matches

by Captell
Sat Aug 06, 2011 9:11 pm
Forum: .NET
Topic: Datatable not showing all data depending on chart size
Replies: 6
Views: 2307

Re: Datatable not showing all data depending on chart size

Hi there,
I used your sample application found http://www.teechart.net/support/downloa ... hp?id=1928 and changed the number of bars from 5 to 10.

and the problem shows.
by Captell
Tue Aug 02, 2011 10:01 pm
Forum: .NET
Topic: Data table not positioning correctly
Replies: 1
Views: 915

Data table not positioning correctly

I'm using release 4.1.2011.07280 in a vs2003 vb development environment on Windows XP. I'm trying to add a datatable to a chart and have it positioned correctly without using the chart properties editor. Here is my code to add the datatable Private Sub mnuEditAddDataTable_Click(ByVal sender As Syste...
by Captell
Tue Aug 02, 2011 9:34 pm
Forum: .NET
Topic: Demo app failing to start
Replies: 2
Views: 1079

Re: Demo app failing to start

Sorry, I should have mentioned, I'm running on Windows XP.
by Captell
Tue Aug 02, 2011 9:33 pm
Forum: .NET
Topic: Demo app failing to start
Replies: 2
Views: 1079

Demo app failing to start

Using release 4.1.2011.07280 I'm getting an unhandled exception when I try to start the demo app. See the end of this message for details on invoking just-in-time (JIT) debugging instead of this dialog box. ************** Exception Text ************** System.IO.FileNotFoundException: File or assembl...
by Captell
Tue Aug 02, 2011 9:31 pm
Forum: .NET
Topic: Datatable not showing all data depending on chart size
Replies: 6
Views: 2307

Datatable not showing all data depending on chart size

I'm using release 4.1.2011.07280 but this problem also occured in release 4.1.2010.9280. I've created a chart which includes a data table but the data in the datatable only correctly displays when the chart is small or very large. This image is of the chart not showing all the data in the datatable....
by Captell
Tue Aug 02, 2011 9:16 pm
Forum: .NET
Topic: Unable to install July 2011 release
Replies: 3
Views: 1242

Re: Unable to install July 2011 release

okHi Sandra, Thanks for the quick response, I think what happened is that I installed it succesfully first time, then I had to uninstall because I'd left older versions installed and wanted to clean everything up. I then tried the install of the new version again and this is when the error occured. ...
by Captell
Mon Aug 01, 2011 10:07 pm
Forum: .NET
Topic: Unable to install July 2011 release
Replies: 3
Views: 1242

Unable to install July 2011 release

Hi there, I just downloaded the July 28 2011 release and it wont install, it throws the following error. installfail.png I tried uninstalling all existing versions, rebooted and tried again but still getting the same error. I'm trying to install the vs2003 version on a Windows XP virtual machine.
by Captell
Mon Jul 04, 2011 12:48 pm
Forum: .NET
Topic: Charts with data table tool in web application
Replies: 3
Views: 1111

Re: Charts with data table tool in web application

Hi Sandra,
Try your sample without the following

Code: Select all

For i As Integer = WebChart1.Chart.Tools.Count - 1 To 0 Step -1
         WebChart1.Chart.Tools.RemoveAt(i)
Next
I added that to remove the data table because with the data table there it would fail to cast correctly on my next line of code.
by Captell
Sat Jul 02, 2011 4:39 am
Forum: .NET
Topic: Charts with data table tool in web application
Replies: 3
Views: 1111

Charts with data table tool in web application

Hi there, I'm using dotnet version 4.1.2010.9280 and am having a problem displaying charts in a web application where the chart includes a data table tool. Here is the situation. I have a windows form application that allows users to create charts and which stores the .ten file in a database, I rece...
by Captell
Wed Jun 01, 2011 7:56 am
Forum: .NET
Topic: Problem with "data table" tool over writing axis labels
Replies: 13
Views: 4796

Re: Problem with "data table" tool over writing axis labels

Hi Sandra,
I tried your enclosed application but it wont load properly in VS 2003. As mentioned at the start of this thread I'm using vs2003. Do you have a version that loads in VS 2003.

Thanks.
by Captell
Mon May 30, 2011 9:13 pm
Forum: .NET
Topic: Problem with "data table" tool over writing axis labels
Replies: 13
Views: 4796

Re: Problem with "data table" tool over writing axis labels

I have tried your example above and it still doesnt work. Public Class datatable Inherits System.Windows.Forms.Form #Region " Windows Form Designer generated code " 'Form overrides dispose to clean up the component list. Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean) If dispos...
by Captell
Sat May 28, 2011 12:44 am
Forum: .NET
Topic: Problem with "data table" tool over writing axis labels
Replies: 13
Views: 4796

Re: Problem with "data table" tool over writing axis labels

The proposed workaround will also not work if the chart is a horizontal bar.
by Captell
Fri May 27, 2011 11:17 pm
Forum: .NET
Topic: Problem with "data table" tool over writing axis labels
Replies: 13
Views: 4796

Re: Problem with "data table" tool over writing axis labels

This work around doesn't work. Firstly, the onAfterDraw event fires multiple times which results in the chart and datatable being shifted off the visible area, the marginleft and marginbottom values are incremented each time it fires. Secondly, it fixes the datatable in a specific position, so if th...
by Captell
Fri May 27, 2011 10:41 pm
Forum: .NET
Topic: Problem with "data table" tool over writing axis labels
Replies: 13
Views: 4796

Re: Problem with "data table" tool over writing axis labels

The version I'm using is 4.1.2011.4190 in a VS 2003 development environment using VB.Net.
I'l work on a sample today.
by Captell
Wed May 25, 2011 10:52 pm
Forum: .NET
Topic: Problem with "data table" tool over writing axis labels
Replies: 13
Views: 4796

Re: Problem with "data table" tool over writing axis labels

Thanks for the quick reply Sandra, I see from your screen shots that your installations seems to behave a little different to mine, here is a simmilar screen shot showing the missing characters, any ideas on why it's different. n1.png Also, can you explain what the Automatic offset is for. I have ma...