Search found 11 matches

by mendelo
Thu Jul 16, 2009 8:24 pm
Forum: VCL
Topic: TPolygonShape
Replies: 2
Views: 2025

Re: TPolygonShape

Thank you Yeray That does work, but only temporarily. If you perform any other change to the TTree, such as turn off the grid etc. then the image reverts back to a rectangle. Additionally it does weird things to other TTreeNodeShapes, such as causing the images not to display within all other shapes...
by mendelo
Tue Jul 14, 2009 6:29 pm
Forum: VCL
Topic: TPolygonShape
Replies: 2
Views: 2025

TPolygonShape

Is it possible, at this time, to apply an image to a TPolygonShape, with imagealignment of iaCenter and have the image fill out just within the boundaries of the polygon, rather than creating a rectangle?
by mendelo
Sat Mar 01, 2008 1:25 am
Forum: VCL
Topic: TTree Save to Stream
Replies: 7
Views: 6281

Tom

I would be glad to but the PM on this board has been disabled and your profile does not list an email address.

Cheers
Peter
by mendelo
Fri Feb 29, 2008 6:47 pm
Forum: VCL
Topic: TTree Save to Stream
Replies: 7
Views: 6281

Connection Issues

With regards the connection issue, once I save the TTree to stream and reload it from the stream, the connections are no longer visible. Yet I know the components are there, because in designer if I try to add a connection between the same two nodes, I get an error message that states "A component n...
by mendelo
Fri Feb 29, 2008 2:08 am
Forum: VCL
Topic: TTree Save to Stream
Replies: 7
Views: 6281

The Lost Children

Thank you for the insight into the NoOwnerShapes property. I could not find this documented in the help manual. I have moved a little further. A TTree has nodes and child nodes added at runtime. procedure Form1.SaveMyTree(Sender : TObject); begin Tree1.NoOwnerShapes:= false; SaveTreeToStream(Tree1,s...
by mendelo
Mon Feb 18, 2008 7:10 pm
Forum: VCL
Topic: TTree Save to Stream
Replies: 7
Views: 6281

TTree Save to Stream

This is just getting an exercise in frustration. I see in the help that there is a LoadTreeFromStream procedure. Great. However there is no documented SaveTreeToStream. But it exists. So that is good, now I can save the Tree to a database and then reload it. However when I load it I discover that it...
by mendelo
Sun Feb 17, 2008 1:55 am
Forum: VCL
Topic: SaveToStream and Transparency
Replies: 1
Views: 2474

SaveToStream and Transparency

I can add a TTreeNode Shape TTreeNodeShape.Image.Assign(SomeBitmap); TTreeNodeShape.Image.Transparent:= true; TTreeNodeShape.ImageAlignment:= iaCenter; All is good , the image shows the background. However if I SaveTreeToStream(MyTree,strm) or SaveTreeToFile(MyTree,'C:\mytree') and then reload the f...
by mendelo
Fri Feb 15, 2008 12:46 am
Forum: VCL
Topic: Draw on Canvas
Replies: 3
Views: 3629

Hi Tom Thanks for the reply I am using the TTree components for users to map out farms and overlay building, pens and other features, using TTreeNodeShapes. This is all working very well. The background is an overhead image of the farm from Google Earth that is used as a template. Some features on t...
by mendelo
Sun Feb 03, 2008 3:01 am
Forum: VCL
Topic: Draw on Canvas
Replies: 3
Views: 3629

Draw on Canvas

If on the mouse up event I use

Tree1.Canvas.Draw(X,Y,Bitmap)

this works fine until I do anything else, such as turn on or off the grid, go to add a TreeNodeShape, etc. then the image disappears. How can I save the canvas?
by mendelo
Thu Jan 31, 2008 10:39 pm
Forum: VCL
Topic: Polyline/Polygon question
Replies: 1
Views: 2661

Polyline/Polygon question

I have BDS 2006 running on XP sp 2 . I create a form, drop a TTree on it then double click on the TTree component to open the editor. I select either the polygon or polyline tool. Then I click in the editor field and start laying out my polygon or polyline. How do I tell the mouse I have done with t...
by mendelo
Thu Jan 24, 2008 2:34 am
Forum: VCL
Topic: Shadow not showing
Replies: 1
Views: 2403

Shadow not showing

Probably a simple answer that I cannot figure out. I cannot get the shadow to appear in an Imageshape. Everything works fine but no shadow. Code as follows: procedure AddShape1 (Bitmap1 : TBitmap , TreeX,TreeY : integer); var V : TImageShape; begin With Tree1 do begin V:= TImageShape.Create(Tree1); ...