Faulty topics etc

TeeGofer general
Locked
El Maco
Newbie
Newbie
Posts: 6
Joined: Mon Nov 24, 2003 5:00 am

Faulty topics etc

Post by El Maco » Wed Jan 07, 2004 1:09 pm

To check that my documentation is detailed enough, I sent a versiononestandalone file to my employer as a preview of my ongoing project. He found a few interesting topics that I had missed myself:

- Quite a few topics are faulty. In Teegofer MyClass has topics MyClass Members, MyClass Properties, MyClass Methods etc. In the compiled helpfile some of these topics are "renamed" to MyClassMethods, MyClassProperties, i.e. the same name concatenated and without the bookimage in helpfile (image is page with questionmark).
Which topics that are correct differ from class to class.

- I have a class named XMLUserSettings that has an inner class Setting. In the helpfile for Settings, I get the following topics: XMLUserSettings.Setting Members (questionmark image), Setting Constructor(questionmark image), XMLUserSettings.Setting Fields (book image), SettingMethods (questionmark image). Why is not the same namingstandard and imagestandard used?

- My comment: I have 4 assemblies in my project. I have written the most extensive text and examples for each assembly directly in the contents for the assembly. For 3 of my assemblies, the contents has been changed to contents of other classes/methods. Yes, I am quite sure that I have not changed this myself. This must have happened in some later versions otherwise I should have noticed it before.

Thanks for a quick reply!
/ Markus

Christopher
Site Admin
Site Admin
Posts: 1349
Joined: Thu Jan 01, 1970 12:00 am
Location: Riudellots de la Selva, Catalonia
Contact:

Post by Christopher » Thu Jan 08, 2004 8:18 am

Hi --
To check that my documentation is detailed enough, I sent a versiononestandalone file to my employer as a preview of my ongoing project. He found a few interesting topics that I had missed myself:
Presumably you are using TeeGofer v2.5.0.1?

I've tried reproducing the problem using the output from the SteemaSimpleControl example which can be found under:
C:\Program Files\Steema Software\TeeGofer v2\Examples\SteemaSimpleControlSolution\SteemaSimpleControllLibrary\bin\Debug\SteemaSimpleControl.dll

Creating a new TeeGofer project from the SteemaSimpleControl.dll
example assembly seems to correctly build versiononestandalone files; would you mind please modifying the example project (SteemaSimpleControllLibrary.csproj) and sending it to me at chris@steema.com so that I can reproduce these problems here?

Many thanks,
Thank you!

Christopher Ireland (Steema crew)
Please be aware of the newsgroup archives:
http://www.teechart.net/support/search.php
http://groups.google.com
http://codenewsfast.com/

Locked