Items missing from legend

TeeChart VCL for Borland/CodeGear/Embarcadero RAD Studio, Delphi and C++ Builder.
Post Reply
TestAlways
Advanced
Posts: 228
Joined: Tue Aug 28, 2007 12:00 am
Location: Oregon, USA

Items missing from legend

Post by TestAlways » Tue Feb 17, 2015 7:41 pm

XE2, TChart Pro 2015.14.150120 32bit. VCL

In the attached demo, when the legend is on the right, all of the legend items are included:

Image

But when the legend is on the bottom of the chart, it does not display all of the legend items (#9 and #10 are missing):

Image

How can I fix this? And if this is a bug, can I get the patches to fix this?

Thank you,

Ed Dressel
Attachments
Legend Items Disappear.zip
(5.91 KiB) Downloaded 160 times

Yeray
Site Admin
Site Admin
Posts: 8853
Joined: Tue Dec 05, 2006 12:00 am
Location: Girona, Catalonia
Contact:

Re: Items missing from legend

Post by Yeray » Wed Feb 18, 2015 11:13 am

Hi Ed,

Take a look at these 2 threads and the related tickets on the tracker:
Wrond legend display with 2015.14 update: B1030
Problem with legend and 2015 version: B1110

As you'll see in the last comment on B1030, this has been reopened to be revised.
However, if you are not using checkboxes it could work fine for you, so I'll send the modified units to the mail account you have registered in this forum.
Best Regards,
ImageYeray Alonso
Development & Support
Steema Software
Av. Montilivi 33, 17003 Girona, Catalonia (SP)
Image Image Image Image Image Image Please read our Bug Fixing Policy

TestAlways
Advanced
Posts: 228
Joined: Tue Aug 28, 2007 12:00 am
Location: Oregon, USA

Re: Items missing from legend

Post by TestAlways » Wed Feb 18, 2015 6:52 pm

My demo still shows the same problem. I checked that the DCUs were newly compiled (not using BPLs at runtime), I checked the source directory for the TeeRecompile. Did a build all.

Any suggestions?

Ed Dressel

Yeray
Site Admin
Site Admin
Posts: 8853
Joined: Tue Dec 05, 2006 12:00 am
Location: Girona, Catalonia
Contact:

Re: Items missing from legend

Post by Yeray » Thu Feb 19, 2015 10:02 am

Hi Ed,

I'm afraid I sent you a wrong version of the file.
I'm sending you the correct one again.
Excuse me for the confusion.
Best Regards,
ImageYeray Alonso
Development & Support
Steema Software
Av. Montilivi 33, 17003 Girona, Catalonia (SP)
Image Image Image Image Image Image Please read our Bug Fixing Policy

Post Reply