Page 1 of 1

TeeGDIplus

Posted: Tue Oct 02, 2012 7:51 pm
by 10551030
Hi, just installed TeeChart 2012.06 and wanted to give a try to GDI plus as a customer complains about speed and wonder if it would help.

I added the component to the form and got

[BCC32 Error] Teegdipapi.hpp(525): E2019 'TeeGDIPAPI__4:: :: :: ()' cannot be declared in an anonymous union
[BCC32 Error] Teegdipapi.hpp(532): E2019 'TeeGDIPAPI__4:: :: ()' cannot be declared in an anonymous union
[BCC32 Error] Teegdipobj.hpp(47): E2238 Multiple declaration for '_fastcall TGPRegion::TGPRegion(void *)'
[BCC32 Error] Teegdipobj.hpp(39): E2344 Earlier declaration of '_fastcall TGPRegion::TGPRegion(void *)'
[BCC32 Error] Teegdipobj.hpp(290): E2238 Multiple declaration for '_fastcall TGPBitmap::TGPBitmap(void *)'
[BCC32 Error] Teegdipobj.hpp(269): E2344 Earlier declaration of '_fastcall TGPBitmap::TGPBitmap(void *)'
[BCC32 Error] Teegdipobj.hpp(878): E2238 Multiple declaration for '_fastcall TGPGraphics::TGPGraphics(void *)'
[BCC32 Error] Teegdipobj.hpp(871): E2344 Earlier declaration of '_fastcall TGPGraphics::TGPGraphics(void *)'

Any clues as why it aint working out of the box

Thanks

Re: TeeGDIplus

Posted: Tue Oct 02, 2012 7:55 pm
by 10551030
btw, its under XE2 (CBuilder)

Re: TeeGDIplus

Posted: Wed Oct 03, 2012 8:04 am
by yeray
Hello,

I've created a new simple C++Builder project in XE2 that uses a TChart v2012.06 and GDIPlus.
Find it attached. It builds and runs fine for me here.

This makes me think it has to be something related to the paths. Could you please check the TeeChart paths are on the according lists and on the top of the same? At "Tools/Options..." menu, make sure the following paths are on the top of the lists:

- In the "Environment Options/C++ Options/Paths and Directories/Selected Platform (32-bit Windows)/Include path" list there should be a reference to your TeeChart Include path (by default at "C:\Program Files (x86)\Steema Software\TeeChart 2012 for RAD XE2\Delphi16.win32\Include").

- In the "Environment Options/C++ Options/Paths and Directories/Selected Platform (32-bit Windows)/Library path" list there should be a reference to your TeeChart Library and Obj paths (by default at "C:\Program Files (x86)\Steema Software\TeeChart 2012 for RAD XE2\Delphi16.win32\Lib" and "C:\Program Files (x86)\Steema Software\TeeChart 2012 for RAD XE2\Delphi16.win32\Lib\Obj").
CBuilder_GDIPlus.zip
(5.37 KiB) Downloaded 240 times

Re: TeeGDIplus

Posted: Thu Oct 04, 2012 12:00 pm
by 10551030
Sorry I made a mistake, this project is actually under CBuilder 2007, I have checked and cleaned the path with same result...

Re: TeeGDIplus

Posted: Fri Oct 05, 2012 8:47 am
by yeray
Hi,

You are right. I've reproduced the problem so I've added it to the defect list to be revised asap (TV52016375).

Re: TeeGDIplus

Posted: Wed Jun 19, 2013 4:47 pm
by 10046493
Yeray

Has this issue been fixed?

I have just upgrade my TeeChartPro to 2013.08 (I am using C++Builder 2007) and, for the first time, I get:

[C++ Error] Teegdipapi.hpp(531): E2019 'TeeGDIPAPI__4:: :: :: ()' cannot be declared in an anonymous union

I have checked my paths in the Tools > Options box, where I use $(TEEINCPATH) and $(TEELIBPATH), and these are defined during TeeChart setup as:

$(TEEINCPATH)
C:\Program Files\Steema Software\TeeChart 2013 for Delphi 2007\Delphi11\Include

$(TEELIBPATH)
C:\Program Files\Steema Software\TeeChart 2013 for Delphi 2007\Delphi11\Lib


I still get the error.

Any help you can give would be approciated.

Andrew Bond

Re: TeeGDIplus

Posted: Thu Jun 20, 2013 11:16 am
by narcis
Hi Andrew,
Has this issue been fixed?
I'm afraid not.
I have just upgrade my TeeChartPro to 2013.08 (I am using C++Builder 2007) and, for the first time, I get:
From this release GDI+ canvas is the default one. Hence you get it from the beginning. This is a known issue we are currently investigating. In the meantime, the only solution is disabling GDI+ from your application at the chart editor -> Chart -> 3D -> Render. You will also need to remove TeeGDIPlus references from your unit's .hpp and .cpp files.

Re: TeeGDIplus

Posted: Fri Jun 21, 2013 11:33 am
by 16463655
Narcis
the only solution is disabling GDI+ from your application at the chart editor -> Chart -> 3D -> Render. You will also need to remove TeeGDIPlus references from your unit's .hpp and .cpp files.
This doesn't work. I have removed all reference to TeeGDIPlus from my code, but other TeeChart heards include <Teegdiplus.hpp> ... in particular TeePrevi.hpp, which gets included via TeeEdit.hpp and other headers.

So what do I do? This release of TeeChart totally breaks my application at compile time.

Help!

Andrew

Re: TeeGDIplus

Posted: Fri Jun 21, 2013 1:52 pm
by narcis
Hello Andrew,

If you need to use those units you should revert your TeeChart installation to build 2013.08.130430 (beta with XE4 support) or build 2012.07.121105 (stable).

Apologies for the inconvenience caused.

Re: TeeGDIplus

Posted: Mon Jun 24, 2013 12:46 pm
by 16463655
Narcis

Thanks for the workaround.

I'm surprised you switched the default behaviour while this bug (TV52016375) is still outstanding.

I trust you will provided a fix before long, since it prevents C++Builder 2007 customers from using the latest features of TeeChart.

Andrew

Re: TeeGDIplus

Posted: Thu Nov 14, 2013 4:09 pm
by narcis
Hello everyone,

Just to let you know that TV52016375 has been fixed for the next maintenance release, which we expect will be out very soon.