Page 1 of 1

Delphi XE - Issue Installing TeeChart

Posted: Wed Jul 11, 2012 3:42 am
by 10550242

I have Delphi XE installed on a Windows 7 Pro machine.

I had installed TeeChart in the default c:\Program Files X86 directory structure - but when I tried to compile anything that used TeeTools - it told me that I could not compile that file. I guess it was an issue with the c:\ProgramFiles redirection in Win7 - so I uninstalled and resinstalled it into a new directory c:\delphi\...

It installed fine - but when I tried to install the Report Builder components - I get an error. It tells me that it cannot open file dcc32.txt in the c:\Program Files(x86)/... directory structure. And of course it is correct - because it is not there.
Yet in the TeeChart directory int he RB TeeChart Package Builder - it shows the proper directory of c:\Delphi\...

Have you ever seen this before? I know this is a RB issue - and I will be asking them as well - but Ithought I would also check here incase therewas an issue with a registry entry or something similar.

Bradley MacDonald

Re: Delphi XE - Issue Installing TeeChart

Posted: Wed Jul 11, 2012 4:15 am
by 10550242
OK - I have tried uninstalling both TeeChart and RB again - and have just re-installed TeeChart itself.

When I add a TeeChart to a new Project - it compiles fine
However, if I add the unit TeeTools to the Uses clause - then it fails with the message

DCC Fatal Erro Unitform_graphview F2063 Could not compile used unit TeeTools.pas

I did a check - and I have the correct directory in my Library Path...
C:\Delphi\Components\TeeChart Pro 2010 Full Source Code\Sources\Compiled\Delphi15\Lib

and the TeeTools.dcu is there.

If I start a new project - and put a TChart on it - and then put on a TeeCommander - and then compile - it gives me the same basic error tellilng me that it could not compile unit TeeAxisBreaks.pas... and that file is in the directory above as well..

Any thoughts as to what I have done wrong?


Re: Delphi XE - Issue Installing TeeChart

Posted: Wed Jul 11, 2012 2:34 pm
by yeray
Hi Bradley,

Please try going to Tools -> Options -> Environment Options -> Delphi Options -> Library - Win32 -> Library path and move TEELIBPATH to the top of the list.