Open of Form with TreeMap - causes CPU Usage to climb..

TeeChart VCL for Borland/CodeGear/Embarcadero RAD Studio, Delphi and C++ Builder.
Post Reply
TimeAcct
Newbie
Newbie
Posts: 43
Joined: Wed Sep 03, 2008 12:00 am

Open of Form with TreeMap - causes CPU Usage to climb..

Post by TimeAcct » Sat Feb 26, 2011 11:54 pm

Hi,

I have an interesting problem. I have a TreeMap graph setup on a form. When I try to open that form - it causes the CPU usage to climb to 13% on my Quadcore CPU - and Delphi basically hangs.
I am not convinced it is a TeeChart issue - as I have some other funny things happening with Delphi - but thought I would check to see if you have seen this happen elsewhere??

Bradley

Yeray
Site Admin
Site Admin
Posts: 8940
Joined: Tue Dec 05, 2006 12:00 am
Location: Girona, Catalonia
Contact:

Re: Open of Form with TreeMap - causes CPU Usage to climb..

Post by Yeray » Mon Feb 28, 2011 11:55 am

Hi Bradley,

Can you please tell us what IDE and TeeChart version are you using?
Could you also please tell us the exact steps we should follow to reproduce the problem here from a new simple application?
Thanks in advance.
Best Regards,
ImageYeray Alonso
Development & Support
Steema Software
Av. Montilivi 33, 17003 Girona, Catalonia (SP)
Image Image Image Image Image Image Please read our Bug Fixing Policy

TimeAcct
Newbie
Newbie
Posts: 43
Joined: Wed Sep 03, 2008 12:00 am

Re: Open of Form with TreeMap - causes CPU Usage to climb..

Post by TimeAcct » Mon Feb 28, 2011 4:41 pm

Hi

I have not been able to reproduce it at this time - except in our large project. That is partly the reason for the question :)

As to which version - I am using Delphi XE Enterprise - and the first TeeChart Version to work with Dephi XE.

Bradley

Yeray
Site Admin
Site Admin
Posts: 8940
Joined: Tue Dec 05, 2006 12:00 am
Location: Girona, Catalonia
Contact:

Re: Open of Form with TreeMap - causes CPU Usage to climb..

Post by Yeray » Tue Mar 01, 2011 2:59 pm

Hi Bradley,

I'm trying to reproduce the problem in a new simple application (RAD Studio XE + TeeChart Pro v2010.02) with only a chart and a button in the form. Here is the code I'm running:

Code: Select all

uses TeeWorldSeries;

procedure TForm1.Button1Click(Sender: TObject);
begin
  with Chart1.AddSeries(TWorldSeries) as TWorldSeries do
  begin
    Map:=wmWorld;
    FillSampleValues();
  end;
end;

procedure TForm1.FormCreate(Sender: TObject);
begin
  Chart1.View3D:=false;
  Chart1.Legend.Visible:=false;
end;
Looking the Task Manager when clicking the button, I see the application taking the 8% of the CPU for about a second and then the application continues using 0% CPU if I don't interact with the chart.
I've tested it in an AMD 3800+ with 3.5GB RAM.

Maybe your application is doing something, repainting the chart continuously?
It will be helpful if you can arrange a simple example project we can run as-is to reproduce the problem here.

Thanks in advance.
Best Regards,
ImageYeray Alonso
Development & Support
Steema Software
Av. Montilivi 33, 17003 Girona, Catalonia (SP)
Image Image Image Image Image Image Please read our Bug Fixing Policy

Post Reply