Search found 5 matches

by dsoballe
Sun Sep 20, 2020 8:23 pm
Forum: VCL
Topic: Series ONCLICK and Chart1SeriesClick Events Not Functioning
Replies: 2
Views: 1866

Re: Series ONCLICK and Chart1SeriesClick Events Not Functioning

Answer to my own question, others may find this helpful. Because enlarging the size of the chart seemed to alleviate the "dead points" problem, it suggested to me that the algorithm used to calculate space for the Mark was deciding there was not enough room and so cancelled the series click. Zooming...
by dsoballe
Sat Sep 19, 2020 8:18 pm
Forum: VCL
Topic: Series ONCLICK and Chart1SeriesClick Events Not Functioning
Replies: 2
Views: 1866

Series ONCLICK and Chart1SeriesClick Events Not Functioning

I am using TeeChart Pro V2020 32bit VCL and have found that the Series ONCLICK event and Chart1SeriesClick Event seem to be "disabled" on some (not all) series points AFTER an initial click on these same points is successful. Other points in the same series continue to respond to clicks, but the "di...
by dsoballe
Sat Jun 27, 2020 7:40 pm
Forum: VCL
Topic: getmarktext not triggering for every value in series
Replies: 3
Views: 3876

Re: getmarktext not triggering for every value in series

That did the trick - thanks again for your help. I'm kind of surprised this series property does not seem to appear anywhere in the object inspector or in the series editor
by dsoballe
Fri Jun 26, 2020 7:41 pm
Forum: VCL
Topic: getmarktext not triggering for every value in series
Replies: 3
Views: 3876

Re: getmarktext not triggering for every value in series

Marc wrote:
Tue Jun 23, 2020 10:23 am
Hello,

Default behaviour may have changed between versions. TeeChart now checks for Marks that will fit and reduces the Draws accordingly.

You can disable that behaviour via:

Code: Select all

Series1.CalcVisiblePoints := False;
Regards,
Marc Meumann
Many thanks, I'll give that a shot.
by dsoballe
Tue Jun 16, 2020 5:24 pm
Forum: VCL
Topic: getmarktext not triggering for every value in series
Replies: 3
Views: 3876

getmarktext not triggering for every value in series

I am using TeeChart Pro v2020.30 32bit VCL. I have an application that worked just fine with an older version (TeeChart Pro v2011.03.30407 Win32), but in this version (Delphi Rio 10.3) the marks on a line series have an issue - When I have more than about 500 values in the series, The OngetMarkText ...